Tinymce-Editor fehlt

Es stellte sich dieses Problem:
Nach einer Neuinstallation und der Änderung auf ein anderes Template (das vorher wunderbar funktionierte) ist der voreingestellte Editor Tinymce weg. Auch der Login-Button ist weg. Es wird nur noch das HTML-Fenster angezeigt, ohne Änderungsmöglichkeiten.
Das Template habe ich unverändert einfach in den template-Ordner hineinkopiert und unter 'Einstellungen -> CMS' aufgerufen. Nach dem Sichern erscheint unter 'Einstellungen -> CMS', dass das Passwort nur ASCII-Zeichen enthalten dürfe.
Viel Schlimmer ist: Ein Rückgängig-Machen ist nicht möglich! Das Sichern funktioniert nicht mehr.
Es bleibt nur die über Neueinspielung von config.php in den Ordner cmsimple.

In meinem Fall wurde im Template memberslogin() aufgerufen, aber das Plugin war gar nicht installiert.
Beim Plugin privacy() ist auf dem (nur) weißen Bildschirm nur zu lesen: Fataler Fehler.

Eigentlich sollte immer etwas gemeldet werden. Ohne Debug-Modus einfach nur, dass ein fataler Fehler aufgetreten ist.
In solch einem Fall soll dieser aktivieren sein. Tut man das, dann sollte eigentlich gemeldet werden, dass die entsprechende Funktion nicht definiert ist bzw. das Plugin fehlt (also nicht installiert ist).
Diese Info wird man aber nicht unbedingt zu Gesicht bekommen, je nachdem wo das Plugin genau aufgerufen wird; z.B. in einem HTML-Kommentar, oder in einem Bereich der per CSS versteckt wird, etc.

Den Debug-Modus hatte ich irgendwie nicht mehr im Hinterkopf.

Grundsätzlich gilt: Wird das Template nur unvollständig ausgegeben, also fehlt (wie bei mir) der Editor Tinymce, dann liegt das oft an einem Pluginaufruf im Template, der nicht ausgeführt werden kann (entweder weil das Plugin nicht installiert ist, oder weil man sich vertippt hat).

 

Sie sind hier: Startseite > Templates > Tinymce-Editor fehlt

Wir würden gerne Cookies auf Ihrem Rechner platzieren, um uns zu helfen diese Website zu verbessern. Erfahren sie mehr über diese Cookies in der Datenschutzerklärung.

Suchen